Back once and for all!

Post all general things in here.

Moderator: Moderators

Real Member
User avatar
Posts: 45
Joined: 16 Jun 2012 11:47

Back once and for all!

Postby N3ST » 31 Oct 2014 10:06

Hello guys,

I am finally back, I was struggling for the last to make GC work fine with my new gaming laptop.

With My old laptop I was only able to install Windows 8.1 has the legacy bios was giving me Blue Screen when installing the Intel AHCI driver.

And thank to the bad UEFI bios implementation on the P170EM (I7-3740MQ + AMD 7970M) I was not able to install Windows 7.

Now with the new laptop P170SMA (i7-4910MQ + Nvidia GTX 880M) I was able to install Windows 7 with UEFI support.

Even on my girl Friend laptop (MSI I3-3110M + Nvidia 640M)when I changed it to Windows 8.1, the same issues appears.

I tried to make GC work with Windows 8 and 8.1, and I relaly tried everyhting (differents driver set, different configuration, Bios, and even tried virtualbox and wmware workstation), but nothing worked.

Even in normal game I was struggling to get them work right.

The best exemple is Guild Wars, on Windows 8 and 8.1 I the GPU usage and FPS were fluctuacting a lot.

Now On Windows 7, Guild Wars 2 is rock stable at 60 FPS all the time, with no lags and not stutter.

Windows 8 and 8.1 is breaking game experience for Nvidia Optimus and AMD Enduro!!!

This asumption is based on facts and tests, I tried everyhting I could to make my game experience stable and to be able to make GC run properly.

Now that I fixed that, see you this weekend :D

N3ST

Board-Major
User avatar
Posts: 94
Joined: 27 Jan 2012 23:08
Location: Lisbon - Portugal

Re: Back once and for all!

Postby mind-pt- » 31 Oct 2014 16:45

welcome back mate, just a question: Did you download GC again? did you use the link in the blog? did it give you any problems during install? I am just asking this because we had a player reporting that he was having such problems.

thanks and see you this evening : )

Real Member
User avatar
Posts: 45
Joined: 16 Jun 2012 11:47

Re: Back once and for all!

Postby N3ST » 31 Oct 2014 17:09

Hello mindt-pt-,

I donwload the latest verison from GOG a few days ago.

I never had any problem installing or launching the game.

The probleme comes fron Windows 8 and 8.1.

The dual graphic systems on the laptop with both intel and nvidia is broken in this OS.

The dedicated GPU doesn't have a direct link to the monitor, and need to go throught the intel graphic.

For some reason Windows 8 and 8.1 are cause a lot of instability in all games, and GC was runing only at 30 fps or less, and falling down to 20 fps, and when gameranger launched the game the framerate was divided by 2, unplayable.

Since I downgraded to Windows 7, every single games works fine.

Best regards,

Vincent

Return to Ground Control - General

Who is online

Users browsing this forum: No registered users and 1 guest